Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

  • Announcements

    • Kent

      Sign In or Password Problems?   10/09/2016

      If you can't Sign In, you need to reset your password.  Use the Forgot Your Password link at the bottom of the Sign In screen, and the site will send you an email to reset it. If you have an AOL email account, use the Contact Us link at the bottom of the screen -- AOL is intermittently blocking email from the site.
    • Kent

      Feedback Please!   10/28/2017

      See News and Announcements forum.
Sign in to follow this  
JBLACK

MY FIRST TRACTOR WITH RUNNING BOARDS!

Recommended Posts

JBLACK
Well, I really did it this time wife and kids went out of town for the holiday and I picked up another simplicity local dealer didn`t know he had it sitting out back so I asked about it and he looked it over and said as it sits for 200.00 It is a 7010-6 with deck needs headlghts and cosmetics but looks to be complete.The only trouble is when I hooked the battery up I get nothing no clcking or anything the motor is not tight this is my first encounter with a kohler engine/starter alternator what should I check for? any imput will be appreciated.:)?JBlack

Share this post


Link to post
Share on other sites
KenK
Could be a bad switch or maybe a bad circuit breaker.Try a jump wire between the two large posts on the starter solenoid.It should turn over if it does but won't start try another jump wire from the positive battery to the plus side of coil.Doing both of these will bypass all safety and start switches.The battery is full charge?Good luck.:)

Share this post


Link to post
Share on other sites
Kent
The rear lift itself will fit, but it uses a different "stepped collar" on the left hitch upright, unless I'm mistaken. You'll also have to use a lift cable instead of the solid rod.

Share this post


Link to post
Share on other sites
Karl_Brandt
I also have a AC 7010-6. Check the safety switch to see if it works,make sure the gear shifter is in the middle position for starting. Run a battery cable to the starter.

Share this post


Link to post
Share on other sites
JBLACK
Well , starter will turn engine over when jumped from battery. new solinoid, new switch ,new battery, cables, new amp meter, checked the fuse still no juice???? what am I missing this should have been a quick fix!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×