Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
tacomac

carb. problem on 18 hp onan

Recommended Posts

tacomac
I seem to have gas to the carburater but the tractor wont run. If i pour gas into the top of the carb. the engine will start but then dies.I pulled the fuel line off at the carb and the gas runs out there. I pushed snow with it last week but this week it startedand ran for about one minute than died and would not start again. Is the float stuck? or could it be froze up?

Share this post


Link to post
Share on other sites
dirtsaver
Earl I have to add Heet or some other drygas to my cans all year because of condensation. I used to have a terrible time with rough starts and freeze ups before I started this. It also helps to have a filter-funnel to fill your tractors with. I really think that with the newer gas cans with long plastic spouts we have now we introduce a lot of gunk into our equipment, much more than when we had the old metal "tractor funnels" with the screen filters on the farm when I was a kid. Larry

Share this post


Link to post
Share on other sites
tacomac
I took the top off of the carb. today and the pin that holds the float had slid over out of its slot. I put it back where it should be, put the top back on and the tractor started right up. It ran about a minute and did the same thick again. Than my wife made me go Chrimas shopping for the rest of the day. Whoopee, I guess I will try again tomorrow.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×