Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

  • Announcements

    • Kent

      Sign In or Password Problems?   10/09/2016

      If you can't Sign In, you need to reset your password.  Use the Forgot Your Password link at the bottom of the Sign In screen, and the site will send you an email to reset it. If you have an AOL email account, use the Contact Us link at the bottom of the screen -- AOL is intermittently blocking email from the site.
    • Kent

      Feedback Please!   10/28/2017

      See News and Announcements forum.
Sign in to follow this  
D-17_Dave

CCKB With no Power

Recommended Posts

D-17_Dave
When I got my 620 running I was plenty happy, but I noticed it didn't have the pep it ouwt too. I got to put the deck on and all it would do is open the throttle up and spit out the carb. Got to noticeing it was actually blowing ut the carb. Did some looking and decided the cam was a tooth off. So I pulled it back into the shop and pulled the engine out and looked and the timing marks were lined up. Or were they? I did some closer looking and noticed the keyway on the crank gear had a diff. amount of teeth from the key than the other one I had. A hard look revealed after removing the crank gear it had been installed backwards. It had a mark on the inside also so I guese whoever built it last didn't notice it and put it up wrong. What puzzles me is the amount of wear it had on that rebuild and the fact it ran that long without someone doing something to it. I'll put it back in in the mourning and see if it makes the kind of diff. I'm expecting. Just goes to show you, nobodies perfect and it pays to check everything and not take someone else'es work for granted. :)

Share this post


Link to post
Share on other sites
ROBBYDOB
Good eye on the catch there Dave! The person who did the job was probably completely baffled by the timing marks being right on. Lucky for you to have another to look at and notice the difference. Let us know how your dicovery plays out. Rob

Share this post


Link to post
Share on other sites
D-17_Dave
Well I got the cckb back in the 620 and it's definately better. Still a little on the weak side though if you ask me.:( The problem is everytime I fix one thing I find something else.[:0] Now the hydro. won't go in reverse good. It won't let the linkage move into reverse all the way. Nothings binding so i'm sure it's in the hydrostat unit. B)Good thing I got the 4040 too or this thing would be a basket case. Got to go to SC tomorrow so it will have to wait till sat.:(! Then more fun. Hafta pull 2 rear ends apart to get to it and put it back. With any luck I'll be through in time for supper. One nice thing though, I pulled out the HB212 and serviced her up. I know she won't let me down.:)Wife still thinks I'm crasy for getting the larger tractors, O-well, gotta get dirty and frustrated on something.:por it wouldn't be so satisfying when I do get it done.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×