Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

  • Announcements

    • Kent

      Sign In or Password Problems?   10/09/2016

      If you can't Sign In, you need to reset your password.  Use the Forgot Your Password link at the bottom of the Sign In screen, and the site will send you an email to reset it. If you have an AOL email account, use the Contact Us link at the bottom of the screen -- AOL is intermittently blocking email from the site.
    • Kent

      Feedback Please!   10/28/2017

      See News and Announcements forum.
Smitty

When do you know the Hydro is going Out?

Recommended Posts

Smitty
Thanks for the help thus far on the squeal in my hydro. Oil level fine, belt is cool to touch after two hours of mowing. pto not causing the squeal. Here is the kicker!: After about an hour of use the hydro acts so sluggish and puts such a strain on the engine that it seems to almost want to quit, starts really choking and sputtering, blowing some bluish, white smoke during strain. Could be the engine is loosing serious compression after running for a while. (Is that even possible?) Hydro pump is cool to touch but the gears or (rearend?) below the hydro pump attached to the axle is too hot to touch after mowing. Is that normal? This is driving me crazy.

Share this post


Link to post
Share on other sites
UCD
If you haven't done it I suggest to change the fluid and filter use the recomended Simplicity filter or cross to a WIX or NAPA filter the cheaper one size fits many do not work good. Do a search in talking tractors/Archived Posts for hydro filters, or filters. You will find a lot of info on this and the WIX and NAPA filter numbers to use.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×