Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Briggs actting strange


KSever

Recommended Posts

Been runinng this Briggs 10 HP cast iron for nearly a year now in the Landlord with out any problems except for iceing up in the winter. One problem though---> Runs really good for about two minutes at 3/4 throttle then begins to back fire and wants to quit, runs real good at 1/2 throttle all the time. I am running the coil,points,battery ignition and have tried adjusting the points, Adjusted the carb to run smooth but then again it will start backfiring after about two minutes on 3/4 throttle. I have tried changing the ignition back to the electronic ignition but no change so I put the coil ignition back on yesterday. Seems as though when it wants to kick in with the governor this happens also. I did also change the head gasket yesterday since it was leaking just a bit (got a NOS headgasket). Any ideas and thoughts would be greatly appreciated.
Link to comment
Share on other sites

Sounds like you have a fuel flow problem from the tank to the carb. Runs good till the fuel level drops in the carb. Backfires indicate a lean condition caused by lack of fuel. Check the fuel line and filter. Make sure gas is flowing a full stream.
Link to comment
Share on other sites

My thoughts are the same as Rod. Take off fuel line at carb and blow back into tank and see what happens for a while. Don't be surprised how fast gas tanks collect debris.
Link to comment
Share on other sites

10HorseMan
Blow back into the tank. Depending on how long the fuel filter has been on the tractor it may be stopped up. :D
Link to comment
Share on other sites

Bob and Rod, Thanks for the ideas, I reran the gas line so it had a longer and lower loop going to the carb. Runs like a champ now with no backfire. Didn't think it would run this good, in fact it hasn't since I got the tractor put back together a year ago. Kris
Link to comment
Share on other sites

maxtorman1234
That's pretty much the same problem with the model 19 in my old 725, new gas line didnt help though,
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
×
×
  • Create New...