Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

belt hi/low prob


ehertzfeld

Recommended Posts

Ok I've tryed to figure this out by my self......... well since im posting this you can tell how I ended up. I have a 64 Broadmoor that I repainted. Insteed of putting the two speed in I used a three speed. It has the hi/low pulley. The problem is the darn belt keeps slipping of. It happends wile cluching or just after. This is the belt that only has a Idler pulley. It is not the cluch belt. These have two belts. Has any one ever had this problem? Any ideas? even if you think of somthing so small or stupid please post it. In my rage, I may have over looked somthing. Thanks every one. Elon
Link to comment
Share on other sites

I downloaded the PDF file and it dos not show any type of belt stops. The belt is not a clutched belt. There is only a idler for tention. Elon
Link to comment
Share on other sites

I had a similar problem 3 weeks ago.I had the clutch pedal with so much throw the belt was dangling past stops and pulley guides.Try tightening the clutch pedal so you have to press all the way down to shift it.
Link to comment
Share on other sites

mowerman1193
If I remember right there is a little tab thing that bolts on with the idler pulley that acts as a belt stop..Well maybe not a belt stop but to keep it from hopping off the idler pulley.. I also think there is supposed to be one under the tractor at the center double pulley (right below the dash)..
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
×
×
  • Create New...