Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

  • Announcements

    • Kent

      Sign In or Password Problems?   10/09/2016

      If you can't Sign In, you need to reset your password.  Use the Forgot Your Password link at the bottom of the Sign In screen, and the site will send you an email to reset it. If you have an AOL email account, use the Contact Us link at the bottom of the screen -- AOL is intermittently blocking email from the site.
    • Kent

      Feedback Please!   10/28/2017

      See News and Announcements forum.
Sign in to follow this  
GBrown

Drive problems

Recommended Posts

GBrown
I have a Sovereign 3012 and was getting it ready for spring. I am having problems with the transmission or belts? I put it into gear and it slowly moves forward (doesn't matter what gear) I can smell a belt slipping, but not sure which one or if that is the problem. Any help would be appreciated. Thanks, GBrown

Share this post


Link to post
Share on other sites
ZippoVarga
If you have an after market belt it may be alightly longer than the OEM belt. Try adjusting your bump stop so that when your foot is off the slutch the pedal doesnt hit the stop pin. I did this with both my Simps and if the belt slips with a load I can toe under the pedal and get more grip. Just a thought. Agrees with TOm though, OEM belts last MUCH longer!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×