Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
bigdog46

Kohler KT17 Charging Problem

Recommended Posts

bigdog46
I have an AC 917 with a Kohler KT17 series 1 engine with the 15 amp charging system. It will not charge up the battery and does not show charge on the ammeter when running. I performed the tests recommended in the engine manual and it shows that the stator has a problem because it is only putting out 15 amps AC when running at 3600 rpm. The manual says it should be at least 28 volts AC. I replaced the stator with one that I knew had worked but still had the same problem - l5 volts AC from stator. Any ideas? Thanks.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Who's Online (See full list)

    • Ronald Hribar
  • Today's Birthdays

    1. GLPointon
      GLPointon
      (60 years old)
    2. KYSlowhand
      KYSlowhand
      (74 years old)
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×