Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
SimpleMan

Whew...that was close

Recommended Posts

SimpleMan
Winterized the tractor a few days ago. Chains for the tires, changed oil, installed snowblower. Started snowblowing, everything was going great until I looked at the side of my engine and noticed a stream of oil coming from my engine. I have already fixed the problem, and everything is ok now...but I thought this would be a good one for a "guess the problem" game. Here are the clues...so far. 1) Drain plug, and oil filter were tightened properly. 2) Oil was coming out under pressure. More clues to follow (if needed).

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Who's Online (See full list)

    • ac.d17iv
    • Edwards
    • abu507
    • Dee M
    • 9934059
    • c5penny
  • Today's Birthdays

    1. Andust
      Andust
    2. Noly
      Noly
      (70 years old)
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×