Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Tractor720

AC Starting Issue

Recommended Posts

Tractor720
Good afternoon all! I thought someone else may have some expreience with a starting issue I am having. I thought it was a battery issue but that is not the case. Could be a starter or starter switch gone bad. Sometimes when the key is turned to start it, nothing happens escept dash lights. After trying a couple times it will eventually turn over and then start. Almost seems like a poor connection where the new battery has enough current to jump across the bad connection and start it. not sure how often the starters go bad, but it looks like the engine has to comeout to get the starter burried under it on the right side. Any help would be so greatly appreciated. Thanks to all for such a cool web site. I look forward to being an active member.

Share this post


Link to post
Share on other sites
UCD
Clean all connections on both ends of the Positive and negative cables as well as connections on solenoid. You could also have corrosion in side of the cables. A high resistance connection can cause the symptoms you describe. Then check and clean connections to starter switch.

Share this post


Link to post
Share on other sites
D-17_Dave
Welcome TJ. You didn't mention what tractor your working on but judgeing by your post name I'm gueseing a 720 with a CCKB onan. If thats the case then I'd recomend a search on "Onan's". There are several articles on the starting issues related to these tractors. Worn key switches, old bad corroded safty interlock problems resulting in low voltage going to the starter solinoid. Al Eden has a few extensive posts on the topic. So I won't go into repeating the info. As was mentioned above by Maynard, start w/ the ovious easy stuff and work your way in.

Share this post


Link to post
Share on other sites
Guest
Test - I feel your pain. I went through the same headache with my Pmax and did all of the obvious stuff mentioned above (recommended) but still suffered through the intermittent starter problems until installing Al Eden's Uni-Kit.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Who's Online (See full list)

    • simplewrench
    • lt-scir
    • Hick
    • Bear
    • tamurmueen
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×