Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Ryan

Powermax problem

Recommended Posts

Ryan
I put on the snowblower last weekend and the tractor would not lift it up. The tractor hydraulics did power down and lift the front wheels of the ground but would not release the pressure. I swithed the lines from one side to the other and the tractor lifts the blower but again would not release the pressure to let it back down. It acts like it has a bypass problem. Any help would be greatly appreciated. Thanks, Ryan

Share this post


Link to post
Share on other sites
Ronald Hribar
It may be as simple as one quick coupling not working properly. Are the ends on the tractor exactly the same? Or is the linkage on your valve worn thait only moves in one direction

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Who's Online (See full list)

    • 720nut
    • Bill725
    • simplewrench
    • fredmanzo
    • rokon2813
    • Ronald Hribar
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×