Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
richp

Late model vertical Briggs problem

Recommended Posts

richp
I was wondering if you guys could give me some off brand tractor help. I am working on a friends craftsmen tractor with a Briggs 15.5 ohv vertical shaft engine. When I try to start it, It back fires out the carb inlet. I cleaned the carb 3 times, and no difference. It does have a fuel solenoid on the float bowl. It seams to toggle back and fourth with the key no problem. Both valves are set at correct gap. Any ideas.

Share this post


Link to post
Share on other sites
HubbardRA
It could be that the flywheel key has sheared and the ignition is firing at a time when the valve is open. So check for a sheared flywheel key. I would have suggested valves, if you hadn't already said that they were gapped properly. I fixed one this weekend that had a screw from the carb lodged between the intake valve and seat.

Share this post


Link to post
Share on other sites
richp
One thing I forgot to mention, is when I started working on it, it would sputter and spit out the carb, then all of a sudden I tried it and it ran fine for a few minutes. When I went to restart it, same problem. The fact that it ran fine , would rule out a lot of stuff. I think the fuel solenoid is effected when a safety switch is activated. I don't recall a motor flaming out the carb inlet like this. I'm stumped. My Briggs book doesn't cover these new motors.

Share this post


Link to post
Share on other sites
MrSteele
I'd check the key first. As it is a late model engine, ther is no need to check anything else on the ignition system. If anything else is wrong with the ignition, it wouldn't even backfire. There would be no spark at all.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×