Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

  • Announcements

    • Kent

      Sign In or Password Problems?   10/09/2016

      If you can't Sign In, you need to reset your password.  Use the Forgot Your Password link at the bottom of the Sign In screen, and the site will send you an email to reset it. If you have an AOL email account, use the Contact Us link at the bottom of the screen -- AOL is intermittently blocking email from the site.
    • Kent

      Feedback Please!   10/28/2017

      See News and Announcements forum.
Sign in to follow this  
wminmi

welp, got the B-12 running today....sorta

Recommended Posts

wminmi
took the carb apart on the B&S 12hp and she was WAY nasty! So nasty that whatever was inside the float bowl had actually ate the retaining prongs for the float pin and even had started eating into the carb body :( So, i snatched the carb off my 16hp B&S and tore it down. ALOT better! Got her cleaned out and installed a new 12hp rebuild kit. After priming her with some starting fluid, she came to life!! Runs pretty good.....even though every once in awhile she tends to "surge" and "spit & sputter" but i'm thinking it's due to whatever i couldn't get out of the gastank. The longer she ran, the better she ran so with any luck (fingers crossed here) after running some good clean gas through her she'll straighten up. Other than that, been trying to get ahold of "killerAC" as he e-mailed me about a pulley i need, but haven't had any luck. Everytime i e-mail him, my e-mail keeps getting bounced back ? So, if anybody knows how to get ahold of him (PM maybe?) i'd greatly appreciate it! Also, "solo663", still trying to get back with you as well on the pulley assembly, but have had no luck either. This is the last pieces i need before she's up and moving on her own!!

Share this post


Link to post
Share on other sites
wminmi
yes i did, used the same picture as you posted too. Thinking i'll run some cleaner (seafoam) through her and see what happens. Can't be too bad, like i said, she idles perfect, then starts the surging, then stops and runs perfect again

Share this post


Link to post
Share on other sites
HubbardRA
Wminmi, Check for water in your fuel. I had a similar problem on Saturday. When Dave stopped by my house yesterday, he asked if I had checked for water. Doh!! He was right. As many times as I have been bitten by water in the fuel, and it is always the last thing that I think of. If there is any water in the fuel (from condensation), it will collect in the fuel bowl since gasoline floats on top of water. If you remove the main fuel adjustment needle assembly from the carb, it will allow the fuel to drain from the bowl. If there is any water, it will drain out first, and will look like bubbles in the fuel, which are really water droplets.

Share this post


Link to post
Share on other sites
wminmi
evenin all ~ Rod, i think you're right, water in the fuel. When i flushed the tank and ran new fuel line, i used regular rubber fuel line from the tank to an inline filter, then from the filter i ran a chunk of clear just so i could see what was what. Once i got her running and gas started flowing, i did indeed notice some "clear" bubbles that flowed into the carb. I'll get the bowl drained this friday (day off!!)and give it another shot. Almost 100% posotive that's the culprit

Share this post


Link to post
Share on other sites
wminmi
Just wanted to take a second and update this post a little. Got the bowl drained, and she seems to be running alot better. Every once in a great while she still surges, but for the most part she's running normal. Still have to final adjust the carb, and get the idle set. Seems when i throttle down on the throttle lever, she dies right out. Figuring that is an adjustment issue, nothing big. Thanx for all your help guys!!

Share this post


Link to post
Share on other sites
rjgoth
One additional item to check, would be if there are any air leaks. An air leak in the intake system (between the carb and intake, between the intake and the block, and around the throttle shaft of the carb.) Small airleaks can cause the surging you are describing. Good luck, Ryan PS Post some pictures!:)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×