Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

  • Announcements

    • Kent

      Sign In or Password Problems?   10/09/2016

      If you can't Sign In, you need to reset your password.  Use the Forgot Your Password link at the bottom of the Sign In screen, and the site will send you an email to reset it. If you have an AOL email account, use the Contact Us link at the bottom of the screen -- AOL is intermittently blocking email from the site.
    • Kent

      Feedback Please!   10/28/2017

      See News and Announcements forum.
Sign in to follow this  
Simpleton7016

716 charging system (troubleshooting)

Recommended Posts

Simpleton7016
I sold the 716 and package to a guy (and maybe soon to be member) this weekend from Indiana. He got it home and sounds like he used it all day with great success. However, at the end of the day, he tried to start it and it just "clicked". He called me and I am trying to troubleshoot it from afar. Sounds like a battery or charging system problem. It could be that the battery connectors need to just be cranked down or the posts cleaned. But he said he tried to arc the two posts and got nothing. Now, when I bought it a month ago, the battery started it up no problem then one day it was dead. I assumed it was the battery because it was 5 years old. So I put an almost new battery in it (from my 912) and it fired up and I mowed with it twice. Still no problem. Again, he used it all day with no problem or lights on. But now it sounds like the battery is dead. Question: what typically causes this? Is it a short in the system? Would the machine work all day if the generator was shot? I know that my car will not run very long if the alternator is shot....do these machines operate similarly? Thanks in advance for your thoughts....I am trying to avoid a "negative feedback" on my wife's e-bay account. (Could be grounds for divorce!) :D

Share this post


Link to post
Share on other sites
andy gartner
Hi Generator/good wiring connections/'shorts'- putting those issues aside for now (which are important issues to address)... Experienced mostly with motorcycle batteries-there is something called 'battery sudden death.' You ride for hours, stop for gas, turn bike off, then only one 'click'-when you go to start it. After much investigating, turns out the battery has internally shorted itself out! I'll leave the why's out for now, but it does happen, at least, with motorcycle batteries.

Share this post


Link to post
Share on other sites
GWGAllisfan
They will work a long time with no alternator output. My 712 had a bad ignition switch that didn't send power back to the battery and would run for several hours without problem. A new switch and it charged back up. If, when running, the voltage at the battery is not over 12, then it's not charging. There are a lot of things to check, down load the K series service manual from Kohler and look there. It can be diodes, regulator, etc. Good luck.

Share this post


Link to post
Share on other sites
BLT
Erik, did he say what the current battery voltage was when he got this clicking? Also, after you put in new battery , did the ameter show some sort of positive charge when running?

Share this post


Link to post
Share on other sites
Scott Price
Had the same trouble with my A/C 416. Turned out the ign switch was the culpret. The contact that charged the batt. from the rectfier- regulator output was bad..Found a way to jump it until i find a new switch. the tractor ran sevral days w/o charging. Scott

Share this post


Link to post
Share on other sites
Guest
What's the MFG# of the AC716? I'd like to get the repair manual for that...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×