Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
cwlahr

314H Slow/ Weak Reverse

Recommended Posts

cwlahr
I mowed with my Allis 314H today for the first time today, found a couple of problems. Reverse is ok on a flat level surface, but when trying to reverse on a slight hill, it barely moves and on a steeper hill it won't move. (the tires aren't spinning) Any ideas?? Next problem is that the control handle for the transmission won't stay at one speed, it keeps moving itself back to neutral, kind of a pain holding it up all the time. I would guess that something is loose or worn on the control but not sure without ripping it all apart. Other than that it mows beautifully. Thanks!

Share this post


Link to post
Share on other sites
rsachs
I would suggest first to check the hydro fluid level and make sure it is full. I think if the fliter needed replacement, forward motion would also be affected, but you might want to consider the filter just for peace of mind. Check the Tech Tips for a post by RayS on Vickers Neutral adjustment. My 312 also has difficulty in reverse uphill and I suspect the Vickers will need an overhaul at some point in the future. This subject has been discussed before, so try searching the archives for other info.

Share this post


Link to post
Share on other sites
gtwygreg
I had an earlier post reporting the same issue and got some advice from the members. I haven't had a chance to dig deeper into the issue but I've enclosed a link to my posting. there was some very helpful information. http://www.simpletractors.com/club2/topic.asp?TOPIC_ID=81802


Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×