Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
MarksA-C

6518 Headlights

Recommended Posts

MarksA-C
I have tried everything to get the lights to work. Bulbs are good, lines are good, but they just aren't working. I'm nothing close to a electrician and have no clue what to do. The last thing I want/have to do it take the dash off, that is a royal pain. While my dad was trying out the tractor the lights when on, but then shut off and I just can't get them to work. Any help would be great. Thank You

Share this post


Link to post
Share on other sites
skunkhome
I think I would take a test light , ground it out to the battery and start at the lights and work my way back to the light switch checking to see where you have power. I recently had to replace my toggle switch because there was power going in but none coming out. The toggle seemed to function great with no sign of trouble but it was dead as a doornail.

Share this post


Link to post
Share on other sites
Al
Hi, As I remember the 5200 family had the dual circuit alternator and the lights ran off of an AC winding that only had power when the tractor was running. I am not sure, but think the 6500s were this way also. This from memory and may not be correct. Al Eden

Share this post


Link to post
Share on other sites
joshuaareed
You might also want to check out the ground, if there is a rusty or corroded connection the lights also will not work. You can also use your testlight to check this by placing your clip lead on the positive terminal of the battery and working your way back to the source of the ground.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×