Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
sbull78

landlord help

Recommended Posts

sbull78
howdy guys, i have a 2012 landlord. I need the belt that runs the pto. i ordered what should have been the correct belt and when i got it under proper tension is seemed to big so anyone have any help. maybe the website i got it from is wrong, who knowes. that is why i am asking the experts!!!it is a 3 speed with hi/lo. i have the deck belt and the belt that runs the arbors. i just need the other one. thanks for your help....again!!!

Share this post


Link to post
Share on other sites
sbull78
jeff, that is the exact belt i have maybe i will hook up the entire deck and see if that makes any diffence. when i just put on the pto belt and engage it is a little too long. i will try it with everthing assembled. thanks!!!

Share this post


Link to post
Share on other sites
JimDk
Shaun, That should do the trick. That belt drive setup is one of the more frustrating features of our old tractors. Don't forget to pull the belt tightener handle back after everything is in place. The adjustment on the operating rod is critical, also. You want it adjusted so it goes over center firmly, but not so tight that it stretches the pto belt. Good luck, Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×