Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
MarksA-C

HI-LO noises

Recommended Posts

MarksA-C
Well, the HI-LO I have on my broadmoor is making some weird noises. Its making a clicking sound and at times a r-r-r-r-r-r-r-r-r sound. Is the hi-lo worn out or? It works fine and usually noise free in HI except for a wobble but once its in low its making noises and its hard to shift back to hi. Any info would be helpful Thank you

Share this post


Link to post
Share on other sites
steve-wis
The dog that engages with the bolt heads to stop the housing from spinning is probably worn and letting it slip by, causing the click sound. A new one will fix that, I made my own, pretty simple. As far as hard shifting, does yours have a grease hole in the center of the housing? Mine didn't and when I took it apart it was full of old, hard grease. I cleaned it and regreased it and it works much better. When you shift, you must stop the tractor, and with the clutch fully pushed down, rock the tractor slightly while applying a bit of push to the shifter lever. Don't try to spin the pulley with the clutch, this is what wears them out. I have the manual for the hi-lo in pdf form, if you can't download it from the site let me know and I can send it to you. Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×