Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
ale

Missing part?

Recommended Posts

ale
I have a 3310 V landlord with a Briggs and stratton 10 hp. I would like to put on the snow blower. It looks like the blower gets run off a pulley on the front of the motor[new owner here]and it is missing. Would anyone know what kind of set-up is missing? Can I go to the local tractor supply and get a pulley off the shelf? What size pulley would it take? Any help and info would be greatly appreciated!sm01

Share this post


Link to post
Share on other sites
Simpleton7016
Here is what you need. They are mine and I went through them all....they are complete. [url]http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=180406394531&ssPageName=STRK:MESELX:IT[/url] [url]http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=180403843976&ssPageName=STRK:MESELX:IT[/url]

Share this post


Link to post
Share on other sites
Chris727
A complete PTO will not be available new. Your best bet is to post in the classifieds here and watch on ebay for one like Erik listed above.

Share this post


Link to post
Share on other sites
jbird243
Some of the old snow blowers have the clutch on the blower and all you need is the small pulley attached to the front of the engine shaft to run the blower. A snow blower used on a 2210 will also fit a 3310v. the snow blower part no. is 990519.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×