Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Yeoman627

Broadmoor 738 Mower Deck Lift Problem

Recommended Posts

Yeoman627
I set up one of my Broadmoor 738s with a mower deck today. The problem I'm having is related to the deck lift operation. First of all, I can't seem to figure out where the lift link (chain) attaches to - the outer or inner arm of the lift lever. All my documentation for the deck shows a different lift lever than the one on my machine. The lift lever shown is like the one on my Yeomans and older Broadmoor 728. Anyway, I ended up (after several interations of 'trial and error') with the chain attached to the inside arm. The first problem is when the the lever is pulled back to raise the deck, the side that the chain is attached to (right) raises much more than the other (left) side resulting in the deck sitting uneven when suspended by the lift chain. The second problem, which may be related to the first, is that if the PTO is engaged while the mower deck is raised (ie: blades spinning), the belt flys off the pulleys. One can see when the deck is raised how this could be a problem. Can anyone out there offer any advice for this situation. I used the procedure in the manual for 'leveling' the deck (2 inches) when it is lowered and have no problems with the deck height. Thanks much, Tom Kelly

Share this post


Link to post
Share on other sites
Tragu
I dont know but on my serf 525 I have to go forward to lift the deck with the lift arm that I have to raise the deck and the attachment if I remember correctly attaches to the lift arm on the left side of the arm when looking at it. I am not sure if this helps. Tragu aka Doug

Share this post


Link to post
Share on other sites
carter
Hey tom, On my 738 the chain bolts to the bracket on the "inside" of the frame , that works from the lift lever. I seem to have no problem with my deck, it sits nice and level when raised. When I installed mine I blocked underneath the rear of the deck and bolted the chain to the tightest link. If your two pins are in corectly at the front of the deck, the chain should raise the deck evenly. Sorry , Lou.

Share this post


Link to post
Share on other sites
Yeoman627
Doug - That's how it is on my Yeoman and Broadmoor 728. However, the setup on my Broadmoor 738 (a couple years newer) is different - it doesn't have that 'arm' that bolts on to the lever. For some reason, Simplicity changed the lift mechanism on the 738 series - not sure why. Thanks for your input. Regards, Tom Kelly

Share this post


Link to post
Share on other sites
Yeoman627
Thanks Lou - That's the arm that seemed to make the most sense to me. However, the deck is still not level when raise. Could you please provide me with the how the chain attached to the deck ? The two front pins I'm assuming are correct - there's not too much variation there. Maybe this deck is designed to work with the 728 but needs an 'accessory kit' to work with a 738. Thanks for your help !!! Tom Kelly

Share this post


Link to post
Share on other sites
stevejj56
Sounds like that might - be the wrong deck, I guess its possible. On my deck there is a tab sicking up, the chain bolts to that tab., it is locaded approx. under the in side lift arm. Food for thought, When I instaled mine it also lifted uneven until I noticed the left front pin wasen't in corectly. Other than that, she should lift evenly. Lou.

Share this post


Link to post
Share on other sites
Yeoman627
I just checked the cross reference table, and, while I don't know the actual manufacturer's ID (990422 or 990884) of the mower deck, either one seems to work on both the 728 and 738 Broadmoors - with no kits required. I'll also double-check that front pin as you suggested Lou. Thanks ...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×