Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
GeneW

Front PTO weak?

Recommended Posts

GeneW
My 3314V, 1971 Sovereign has a front PTO for the Blower. It seems to be in the correct adjustment. I even ran it with the acuating rod off so I knew it was engaged. It seems to not have enough rotational power to throw even some powdery snow. Could the shoes or clutch itself be worn. Would I just replace frictional parts or the entire front PTO assembly? Help! I am having a tough time finding this assembly. Any Suggestions?

Share this post


Link to post
Share on other sites
PhanDad
Any lining left in the "cone" part of the clutch? Without the lining, it will slip. Not sure if a replacement cone is available from Simplicity. If it is, I guarantee it will be expensive. Some members have relined the cone with leather to make the old cone serviceable. There's also the possibility that the problem is at the other end - grease on the snowblower driven pulley, broken key, etc. With the belt off, block the rotor from turning. If you can turn the driver pulley by hand, then there's a problem somewhere between the drive pulley and the rotor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×