Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Simplicity85

No Spark 9HP

Recommended Posts

Chris727
Since the mid-80's briggs engines did not have points. They had a magnetron solid state ignition. Make sure the switch is in the on position. If you don't have spark, it could be: plug wiring sheared flywheel key bad magneto

Share this post


Link to post
Share on other sites
ReedS
I'm not familiar with a 233431 but if it's the same block as a 234341, and the block is blank in the points area then it most likely has the pointless magneto. (suffering from crs and can't recall what they call it, magna-spark ?) Make sure the wires to the switch on the shroud aren't shorted to ground and the flywheel is clean and if still no spark I'd be thinking coil.....

Share this post


Link to post
Share on other sites
powerking_one
The 233431 series of engine is the "modernized" version of the old Model 23; still weighs in a 9hp, plain main bearings, 3" bore, 3-1/4" stroke. If yours circa 1990, then there are no points and the block was not machined for them. I'm not sure if Briggs started making the 1 piece Magnetron coils right away starting in 1981 as that was when they introduced the add-on conversion trigger module.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×