Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
mwells

920 deisel not charging

Recommended Posts

mwells
My 920 stoped charging, all the wires are hooked up correctly according to the wiring diagram and have good connections with no broken wires, but I'm not getting any voltage out of the stator. Does anyone know what the voltages should be coming from the stator? Any help would e greatly appreciated! Thanks!

Share this post


Link to post
Share on other sites
sammiefish
i dont know which engine is in the 920 but this article may help regardless... http://simpletractors.com/service/kohler_electrics.htm as mentioned above often it is just a bad connection... go through and clean all the connections to coil and regulator and stator.... good luck... let us know what you find

Share this post


Link to post
Share on other sites
427435
My 7790 stopped charging again after I washed the engine off after overhauling it. I again took the connector off at the regulator and blew it out with my air compressor. Plugged it back together and it's charging again.

Share this post


Link to post
Share on other sites
mwells
Well it started charging again, then it quit again. Must be a bad wire. I've checked all the connectors and couldn't find anything, so I'm just going to rewire the charging system. My dog (1 Year old) got into it earlier this year and decided to try wires for a snack!!:( So I'm guessing a wire got pulled, streched or broke internally. Thanks for the advice!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×