Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
bigdog46

3212V pto to mower deck belt pops off

Recommended Posts

bigdog46
I have a nice 3212V Simplicity with a Briggs 16 hp engine. I have a problem with the pto to mower deck belt popping off when I go from level ground up to a berm near the street. It has the double vee type belt. Any suggestions? Thanks for your help.

Share this post


Link to post
Share on other sites
OrangeMetalGuy
Sounds like something isn't aligned right. Have you had the deck and arbors apart? Maybe the drive pulley is too high or too low? And, do you have the belt twisted the right way... I remember reading that if you have it reversed you may have that problem.

Share this post


Link to post
Share on other sites
bigdog46
Yes, the belt is turned the correct way and the center arbor on the deck has good bearings. As for belt guides, I don't have any on that belt from the pto to the deck pulley. Don't think that there was ever any guides there?

Share this post


Link to post
Share on other sites
Dtrain
Maybe you did this already but take the belt off and flip it over so the top is now on the bottom. I know this sounds crazy, but we had a new belt on a A-C "C" with a 72" Woods belly mower that kept coming off. Our old farmer neighbor told us to flip it over so we did. It never came off again. Evidently, the longer the belt, the more "set" they can acquire during the mfg. process. I don't know if your belt is new or not. FWIW

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×