Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
karting007

7016 Simplicity Tractor

Recommended Posts

karting007
I have a 7016 Simplicity Tractor that we just rebuilt the motor on. This tractor has a 16HP Cast Iron Engine on it. We were trying to start it for the first time this past weekend. It ran fine for our first 15 minute run. We shut it off, changed the oil, tried to restart it and it would not fire. We checked and adjusted the points several times. We also replaced the points for a second time. No luck. It would spark some but was not enough consistently to start the motor. The gap on the armature is set correctly. The points are set correctly. The gap on the spark plug (new also) was set correctly. Anybody have this issue in the past? Any ideals? Thanks!! Tony

Share this post


Link to post
Share on other sites
karting007
quote:
Originally posted by JimDk
Tony, Welcome to the club. As you did not mention changing the condensor, that would be the first thing to try. Good luck, Jim
Sorry Jim, I did not mention it, but the condensor was changed twice also. The parts we originally replaced the points and condensor were all from a local parts store and were not OEM Briggs and Stratton parts. I am going today to pick up B&S parts. Hopefully that will work. Thanks for the reply. Tony

Share this post


Link to post
Share on other sites
RickS
Tony, Remember just because the condensor is new does not mean it works. I would suggest replacing it with one that you know works. Not this only works if you have a second tractor. Or try a third condensor. Welcome to the club! Rick........

Share this post


Link to post
Share on other sites
Brettw
quote:
Remember just because the condensor is new does not mean it works. I would suggest replacing it with one that you know works. Not this only works if you have a second tractor. Or try a third condensor.
Ditto on the plug.

Share this post


Link to post
Share on other sites
karting007
Hi Storm, Yes, we bypassed the condensor and points last night and installed a Mega Fire Control module. It fired right up without even using the choke. It really sounds good and has a lot more get up and go. It has been a long road, but I think it will be worth it in the long run. Tony

Share this post


Link to post
Share on other sites
karting007
Not much to say. I got the tractor mowing and was working out the kinks. Blew a belt on the starter/generator and it hit the gas line. Gas leaked out onto the motor and the tractor caught fire. Now I have to start again. Just my luck. It was mowing good too. Oh well what are ya gonna do?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×