Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Fronkie

720 issue

Recommended Posts

Fronkie
Just picked up an AC 720. It's not the prettiest in the world, but came with a 60" flail mower. I went through and put new plugs, oil, and filters on it. Fired it up and sounded decent. Then I noticed oil blowing out of the filler tube. Is that typical of a cracked head or bad rings or both. It doesn't smoke or anything like that. I guess the tractor had been sitting for some time...could the rings be sticking? Any input would be great to get me going in the right direction.

Share this post


Link to post
Share on other sites
Fronkie
pulled the plugs last night and turned it over a couple times. The left side had less compression than the right. So I dumped some marvel mystery oil in there to sit. I plan to check over all the air ways tonight. I know the tractor was sitting for some time...I think he said 15 years with little or no use.

Share this post


Link to post
Share on other sites
Fronkie
Well, the Marvel Mystery Oil did the trick. I have compression again on both sides, I put a new filler cap seal on the dip, and should be ready to go! But wait, it can't be that simple...went to put the plugs back in and sure enough the left threads are stripped and will not hold the plug in tight....GREAT! I guess I will have to go with a helicoil...Then maybe we will be up and running.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×