Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
lmoret

9020 loading up?

Recommended Posts

powermax_paul
I've got the same problem on one of my 9020's. I'm wondering if it isn't the fuel pump. I've never gotten around to replacing the pump on that tractor with an electric one but someday I'm going to try it. I don't think it could be the governor because it just cuts out. I've found you can catch it back in with the choke, which leads me back to the fuel pump. I have replaced the points and adjusted them, but it still does the same thing. It's peculiar, but it especially does it when the engine is quite hot, from having been under load for some time. Does this sound familiar? Powermax_Paul

Share this post


Link to post
Share on other sites
lmoret
my 9020 after an 1/2 hour of grass cutting if the engine gets a little more load put on it starts to cut out it still runs but very ruff and puts out black smoke. If you stop and let the engine catch up it runs fine. Does this have anything to do with the points,govener,or what?

Share this post


Link to post
Share on other sites
AC_Steve
I've got a 4041 that started doing the same thing when the tractor got under load and RPM'S started to come down. I adjusted the main fuel adjustment on bottom of carb. It was running to rich so I screwed it in 1 1/2 turns and cleared right up. You might try that and count your turns in case you need to return to previous adjustment. Steve

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×