Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Burntime

The new vickers is getting slow as it heats up...

Recommended Posts

Burntime
Will a fluid change do much or is it time to parts her out? I though she was a runner until she started slowing down up the hills today mowing... Any vickers pros out there? Yes it is engauged fully and the belt is tight...

Share this post


Link to post
Share on other sites
sammiefish
well... hmmm.. could the fluid be old and losing viscosity as the temp increases? in that way of thinking I would vote for a fluid and filter change... the filter is available at napa $10-$15 and dexron is cheap.... on mine im just afraid to change the filter for fear of dislodging some debris and allowing it in the system...

Share this post


Link to post
Share on other sites
BLT
Check your four hoses to make sure none of them are crimped and chocking down the oil flow. Slow oil flow will cause things to heat up also. You have a 40 plus year machine. Some of that can't last forever.

Share this post


Link to post
Share on other sites
sammiefish
quote:
Originally posted by Burntime
Thats what I am going to try...I was going to use mercron, is there something better?
like Ray said Dexron/mercon is often speced the same. The officially approved fluid is Dexron "(only)" as stated in the simplicity massey ferguson agco transmission & gearbox lube chart: http://simpletractors.com/club2/topic.asp?TOPIC_ID=22258

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×