Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
leeave96

Prestige Electric PTO Trouble Shooting Questions

Recommended Posts

leeave96
My Dad's Prestige's is having PTO problems. When you flick the switch to engage the mower, the engine dies. My brother says the electric pto is bad, I'm thinking somewhere there is a kill switch that is bad. Anyone had any electric pto troubles with their Prestige tractors (or any other model with similar electric pto) and/or any insight on how to troubleshoot this? BTW, there is no binding from the deck and the pto belt sheave rotates freely when the pto is not actuated. Any tips or advice would be appreciated. Thanks! Bill

Share this post


Link to post
Share on other sites
SmilinSam
Check all the wires going to9 the PTO in and around the framework. My Wifes ConQuest had some wires that were pinched/bared and was causing a short when the PTO was engaged.

Share this post


Link to post
Share on other sites
comet66
Unplug the clutch, turn it on, if the engine dies it's electrical (short, switch, etc.). If not, plug it back in, and remove the belts. If the engine dies it's the clutch. If not it's the PTO or the deck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×