Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Les

1920 won't start

Recommended Posts

Les
My Deutz-Allis 1920 Ultima will not start - the solenoid just buzzes, even when I try to jump it. I assume the starter solenoid is bad - am I correct? Can I get one at an auto parts store, or is this a dealer item? Thanks for the help.

Share this post


Link to post
Share on other sites
MPH
I'm not familiar with the Ultima series. Do they use a true solenoid (like GM) that performs both electrical and mechanical functions, or a relay (like Ford) that just performs an electrical function..? Whether a real solenoid or a relay, “buzzing” (rapid circuit tripping) usually indicates a low battery (or bad ground). A defective solenoid or relay will usually make no sound or will make one normal click but fail to engage the starter. Jumping the battery may not help if the problem is “down line”, like a bad ground, broken wire, corroded terminal, or bad starter.

Share this post


Link to post
Share on other sites
jlasater
Wire brush all the cable connections till they are shiny, get things tight, and see if it works better. Could jump straight to the solenoid and see if it's any better. Likewise, jump from the battery to the terminal from the starter switch and see if it kicks.[A href='http://www.wheatfarm.com']http://www.wheatfarm.com[/a]

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×