Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

  • Announcements

    • Kent

      Sign In or Password Problems?   10/09/2016

      If you can't Sign In, you need to reset your password.  Use the Forgot Your Password link at the bottom of the Sign In screen, and the site will send you an email to reset it. If you have an AOL email account, use the Contact Us link at the bottom of the screen -- AOL is intermittently blocking email from the site.
    • Kent

      Feedback Please!   10/28/2017

      See News and Announcements forum.
Sign in to follow this  
srwven

Shuttle transmission problems

Recommended Posts

srwven
While spreading fertilizer tonight, I started having problems with my 7014 shuttle. When going up steep hills and starting out, sometimes it would hesitate, or seem like it was slipping and make a sort of grinding noise then it would catch and be fine. The belts look fine, have a nice v to them. The pulleys are a little shiny though. Would it make that awfule noise if it were just the belts or pulleys? It goes into reverse fine. I haven't learned much about transmissions, yet. Any help would be appreciated.

Share this post


Link to post
Share on other sites
MPH
I have no experience with shuttle's yet but if you have a manual and pretty good set of tools don't let it scare you into parting with the tractor. I just totally redid my B112 3 speed with some new parts and lots on B10 parts. Couple hours at a time in the eveings..hope you solve it simpler. good luck MPH

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×