Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
igo2xs

throttle linkage 4040

Recommended Posts

igo2xs
good evening everyone i have a problem with my throttle linkage on my 4040 ,when i bought it the throttle cable and lever were missing i can't seem to make the new cable work. missing springs,clips,a top view of the kohler engine with the throttle cable mounts clearly defined would be greatly appreciated thank you all

Share this post


Link to post
Share on other sites
B10Dave
Kohler engine John? They came with a CCKA Onan engine. If yours has been changed to a Kohler I can't help you. If it still has an Onan I can post pics of my Allis 620 linkage for you. Welcome to the site. Dave.

Share this post


Link to post
Share on other sites
B10Dave
John. It was dark in my storage building but I took some pics anyway. The air intake hose covers the governor linkage so these pics probably won't help. If you don't have a manual for your CCKA I could email you one in PDF format.PM me your email if you want the manual. Dave.










Share this post


Link to post
Share on other sites
igo2xs
thanks Dave for your quick response and pictures,my 4040 has a different carb set up, my air cleaner is out the top my trouble is the connection of the cable to the linkage and the placement of the springs that go to the governor ,the cable goes forward to the front then loops back and connects i need to see that area i have the service manual, 4040 chassis manual, and owners manual, all not so clear, again thank you for your help if any one with a 4040 can take some pictures it would be greatly appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×