Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Guest

Bevel box trouble, please help

Recommended Posts

Guest
Hello, I just replaced my damaged bevel box on my B-12 with a good used one. When I got the new box there was no play in the gears. After driving about 10 feet it has a lot of play. The output shaft moves back and forth about 3/8 of an inch when the tractor is at idle in neutral. I think I will pull the rear cover off of it and have a look, but I dread the thought of having to pull the whole tractor apart again to remove the box. Any sugestions ? Do you think one of the bearings in the box is bad ? or is this a shiming problem ? I am also having trouble with the drive belt tension. When the clutch is pushed all the way to the brake position it still does not go into gear without grinding. Should the brake the trans from turning when it is engaged? After I sort all this out, I will still have to get the mower deck drive working. Anybody want a B-12 thats located in Idaho ? Time is running out on this project as I am moving to Central Oregon in August and have several other projects to complete before I go. David Bingham

Share this post


Link to post
Share on other sites
Sandy_Lake_Imp
Make sure the nut on the right end (trans drive side) is tight. A snap ring on the cross shaft contacts the inside hub of the gear,the gear contacts the brng,the brng the spacer,the spacer the pulley & the pulley the nut making for a tight stack. Bill

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×