Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
maxwood

7119 cooling fan?

Recommended Posts

maxwood
hello, I have been working on the 7119, When I got it the seat was smashed down ! the PO had removed the parts that interfered with operation, the hydro release was missing as well as the guard for the hydro pump Fan.I repaired the seat. I got a guard and it would not fit ,the fan blades hit the mesh screen? So I bought a fan on ebay and here is the difference !! Ken in Mi

Share this post


Link to post
Share on other sites
1Litre
Check alignment of the pulley. That may be to far in (near the trans) and is causing your new pully to hit the guard housing. I had one housing mount years back broken off on the bottom where it is bolted on with the brake band .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • BruceH
    • Todd 717
    • SmilinSam
    • thedaddycat
    • RayS
    • Ronald Hribar
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 1 reply
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×