Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
maxwood

wiring ?: repower sovereign

Recommended Posts

maxwood
Hello, I am in the process of repowering my sovereign(1693409) with a briggs vanguard 16 hp The sovereign had a Triad motor and I got a new vanguard (305447) 16 hp. I have the engine mounted and have 2 wires to connect. The tractor has a red/w blue stripe and a white wire the engine has a red wire and another red wire with black shielding over it. I don't want to burn up any coils or other electrics . Any advice or suggestions are appreciated. Thank's ken In Mi

Share this post


Link to post
Share on other sites
Mike
"The wiring was no problem as I had very clear instructions from Jim, take the wire on the tractor which goes to the ignition coil on the KT 17, which is black, to the one labelled ignition on the Vanguard, which happens to be white. Then take the white (or very faded yellow) wire up on the tractor and connect it to the red wire, voltage regulator on the Vanguard. Easy Peasy."

Share this post


Link to post
Share on other sites
maxwood
Hello, this tractor had a triad motor and the wiring is different from a 7119 with a Kohler Kt19 I have looked at the wiring diagrams for the tractor but can't find anything for the briggs motor? Thank's for all the responses Ken in Mi

Share this post


Link to post
Share on other sites
Ronald Hribar
If you reread HotRodTracTors link. You will see where 4 wires go It is very possible that you will have to rewire switch or put a relay in. I think the Triad required power to ignition and the Briggs does not. If you do supply power you will destroy ignition on the motor.

Share this post


Link to post
Share on other sites
BLT
I know where the Traid wires go and where one of them connect. However until I find out about where the red an white are paired go to and where the red wire in the loom goes to so you can finish up your wiring, I am flying in the blind.

Share this post


Link to post
Share on other sites
maxwood
Hello, I was checking for continuity with my ohm meter from the +battery cable to the red\blue wire I have continuity with Key switch ON from the minus battery cable to the White wire I have continuity with KEY switch OFF Thank's Ken in Mi

Share this post


Link to post
Share on other sites
BLT
I know what the function of the red/blue and white wire are. What are the functions of the wires on the Vanguard? What wire is the stop wire on the Vanguard, what wire is the stop solenoid on the Vanguard, does the Vanguard have a low oil pressure signa? I know where the red wire with the attached harness goes, but taking a fyler on the rest could cause electrical damage which is not cheap.

Share this post


Link to post
Share on other sites
maxwood
Hello, I have looked all over the engine and there is NOT a low oil sensor. If the red wire on the engine goes to the voltage regulator will that need 12 volts ? Thanks again for all the help! Ken

Share this post


Link to post
Share on other sites
maxwood
Hello, I got the tractor wired and running! Thank' to hotrodtractors post, and all the members!! here is a photo of a muffler I built for it


and my drive shaft


Thank's again for the Help Ken in Mi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    There are no registered users currently online

  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 1 reply
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×