Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
CDeHeer

Mounted the Deck on the 725

Recommended Posts

CDeHeer
I finally found the time to clean up and mount the deck on my 725.


Deck did have a badly worn mid roller assembly.




I welded some 3/16" x 1 1/4" x 3" bar stock to the brackets drilled to 5/8 to accomadate the new shaft. .




Mounted the deck and it engaged and Whirrred great - for a minute then the motor died. Starts back up but repeats 30-40 seconds after engagement. I suspect the aftermarket plastic float as it sits so high.


Has anyone adjusted the plastic floats with heat on the tab? Any input appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    There are no registered users currently online

  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 1 reply
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×