Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

leeave96

Quick Wiring Question

Recommended Posts

leeave96
So I got the engine reinstalled in my 918H - aka: Sovereign and have a quick wiring question. The positive battery cable goes directly to the starter starter and the negative through a solenoid to ground via the frame or engine block? This is a Kohler Command engine. I think I've got it right. Anyone got a picture of the battery to engine wiring or can describe it? Also, there are a bundle of wires that include the headlights and there is a large thin ring terminal that is bolted/grounded to the engine block below the muffler? I have another tractor that has a Kohler Magnum engine and I believe (if I can remember it right) the battery negative goes directly to ground, the positive to a solenoid and then to the starter. This Command/Simplicity appears to have the solenoid breaking the ground - opposite the Magnum set-up. Any info/pics would be much appreciated. Thanks!!!!!! Bill

Share this post


Link to post
Share on other sites
Brettw
That sounds wrong to me. If the positive goes right to the starter, and if the only way the starter is grounded is by it being mounted (in other words, on any starter I have seen, there is only one wire going to it, a positive heavy wire activated via a solenoid. No ground wire) then the starter would want to run constantly. I am not familiar with the Commands, but what you are stating sounds incorrect. I could be wrong, but positive from battery to solenoid, heavy cable from solenoid to starter is what I would expect.

Share this post


Link to post
Share on other sites
HubbardRA
Ground goes from battery to engine. Positive goes to starter via the solenoid. They are all hooked up this way, or at least all that I have worked on.

Share this post


Link to post
Share on other sites
Al
Hi, If your Sovereign has a TH engine, the cable would go to the starter solenoid. If it has a Command, the solenoid is on the starter and the pos cable goes to the top terminal on it. Al Eden

Share this post


Link to post
Share on other sites
leeave96
Got everything electrically connected correctly for the Command engine - BUT.... When I turn the key, there is a click under the dash - sounds like a solenoid, but appears to be the amp meter. The starter solenoid doesn't engage. The starter solenoid is on the starter vs a separate location like other tractor engines. This Kohler Command is getting to be a pain in the arse...C I've got new batter connectors, good charge on the battery, great ground, but the starter won't engage. Any tips/suggestions would be greatly appreciated. Thanks! Bill

Share this post


Link to post
Share on other sites
leeave96
Al & everyone, Thanks for the replies and help. I pulled a CH engine and put it back-in after changing the head gaskets. I think my problem is in the starter. I was thinking about this last night and remember that from time to time when I would previously start the engine, when I would hit the key, no crank would occur. This might be a continuation of this. The only difference is the loud click under the dash that sounds like a solenoid sound. I think I'm going to pull the starter and work with it on a bench. BTW - the starter will be much lighter to carry around than the whole engine this trip to the basement... :D Thanks!!!!!! Bill

Share this post


Link to post
Share on other sites
BLT
Before you pull off starter , make sure that the blue wire to starter solenoid is firmly attached. It gets its signal from the relay mounted under the steering wheel. If not connected, that is all you get is a 'clicking'. It wouldn't hurt to check to see that your battery is fully charged. A drop in system voltage also could be a problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Who's Online (See full list)

    • abu507
    • GregB
    • PhanDad
    • Tom45
    • tamurmueen
    • lt-scir
    • Brettw
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • Bubba1997

      Bubba1997

      Searching for a Sleeve hitch and breaking plow and other equipment if price is right and also a deck for a B1 thank you 
      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×