Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
bissen83

3416H wickers hydro problems

Recommended Posts

bissen83

Hi

I hope someone can help me, im having problems with the hydro.

When i got the tractor it did´nt move when it was cold, (about 30 seconds) but when the hydro warms up it worked fine. i thought it maybee was a bloked filter

Anyway i still wanted to rebuild the hydro, because it was leaking pretty bad on my new garage floor, so i disconneted the hydro from the tractor and replaced the oil seal in the hydro motor and the o-rings and oil seal in the pump. I did´nt disasamble the transfer block because i did´nt see it as a problem when the hydro was working before.

I put it then back on the tractor and filled it up with ATF dexron automatic transmission oil, running it only at the motorstarter while mowing the lever forward and reverse. When it did´nt take more fluid and no more bubbels was seen it should be ready to go, it says in the workshop manual. But mine is not mowing at all.

Then i searched this forum and found something about shimming the main relief valve, in mine there was 6 shims, in the manual there is only 3. I tried with only 3 shims, without shims and adding shims, and for several hours trying to bleed it from air and still no luck.

Is this really that hard to get this hydro running again, or am i doing something wrong, does anyone tried it before and what did you do to get it running again?

Any help would be appreciated.

Thomas

Share this post


Link to post
Share on other sites
RayS

I have owned several of these Vickers and never had to bleed the system. It should bleed itself into the oil reservoir.

I will send you some vickers repair manual in an email.

Share this post


Link to post
Share on other sites
bissen83

I visual cheked it, all looked fine and new inside, and it worked fine before i changed the seals. One told me if the charger pump is wrong installed, it won´t move, but i did´nt touch the transfer block inside.

Share this post


Link to post
Share on other sites
PhanDad

Another basic, when you move the hydro lever, is the pintle shaft actually being rotated? There is a "Pin-spring" in the "Link Assembly-control" that connects the Link Assembly to the pintle shaft(part 26s and 27 in my Vickers parts manual). The pin could be missing or sheared.

Share this post


Link to post
Share on other sites
MPH

My 3314H bleeds close to dry sitting out over the winter, only uses maybe half a cup mowing all summer though. When I fire it up in the spring I run the engine instead of just the starter. Maybe the starter is not spinning the pump fast enough.

Share this post


Link to post
Share on other sites
bissen83

Hi and thanks for the posts.

The free wheel lever is working fine, and i did run the engine trying to bleed it.

But i may (hope) i know what the problems is. I didn´t had the original gasket for the pump and motor, so i made my own out of .024" gasket paper. And today i talked with another simplicity owner on another forum, and he said the original gaskets are only .015" thick and i could have changed the distance between the pump piston outputs and the transfer block enough to allow the fluid to escape back into the pump housing.

Can anyone maybee confirm that.

Thanks Thomas

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • BLT
    • GregB
    • MARK (LI)
    • wsherm
    • Ronald Hribar
  • Today's Birthdays

    1. comet66
      comet66
      (73 years old)
  • Recent Status Updates

    • MARK (LI)

      MARK (LI)  »  Alltractoredup

      ...This is Mark from Long Island ....Gene told me that you are selling  FEL for a Sunstar....the link he sent me does not take me to it ...I am not on FB myself, but my wife is...is it just on the AC  / Simple group, or is it on the Marketplace?
      · 2 replies
    • F.U.N.

      F.U.N.  »  sandyhillbill

      Dear Sandhillbill
      Can you please copy me on this data, for Sun Star parts list.
      :
      September 12, 2004 Mike I sent you a PM and have all the mfgs. available for the tiller/hitch/pto/liftgroup if you need me to send them to you. Let me know. Thanks, F.U.N.    
      · 0 replies
  • Adverts

×