Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
yukon

motor

Recommended Posts

yukon

ok got the 20hp motor in the sovereign i have 2 questions #1 i cleared the frame on the right side for the oil filter do i have to clear the left side. #2 i have a big gap between the engine and the drive shaft how do i fill that in and do i have to drill new holes for the engine mounting.

IMG_3106.JPG

IMG_3107.JPG

IMG_3106.JPG.bd6f3118aee5a49bba92384db71b200b.JPG

IMG_3107.JPG.31ba6cfbe5c055535c607ddb933c4fa9.JPG

Share this post


Link to post
Share on other sites
Brettw

When I installed my 18 magnum, I did take a small amount out of the frame on the left side. I am not sure this was absolute, but this made it easier to drop in. Not sure what you are asking though, it appears as though the engine is in, so that should answer your question, no?

Not sure of the "big gap" or new holes, I guess that would depend on the engine that was in the tractor originally. You made need a different driveshaft, drill holes, or both in order to fill the gap. I do believe there is no shroud over/around the coupler on the KT or Magnum series.

Share this post


Link to post
Share on other sites
midnightpumpkin

Dave,What is the model number of the engine you are installing?It looks very much like the KT17 series II in my 17GTH-L.It uses a 2 inch thick rubber isolator between the engine and the driveshaft. No filler metal for the gap you are referring to.Download the IPL for 1691957, that should lead you in the right direction.Here are a couple of pictures that may help also. This was a factory installation, the only cut I made was for an oil filter on the right side (filter not installed in pictures).

engine2.JPG

engine1.JPG

engine3.JPG

John U

engine2.JPG.f7b91e4cfd690ca5aa8f6169f32b4def.JPG

engine1.JPG.87083cebebd2d757758ffd7acca554a5.JPG

engine3.JPG.f25bccd31a4ca00892d5185672a1c554.JPG

Share this post


Link to post
Share on other sites
midnightpumpkin

Dave,

I am guessing it is a Magnum 20 out of a Sunstar??

If so, it should bolt in the same as my KT17.

Try lining it up with existing bolt holes and compare it to my pictures.

You will need the rubber bushing and drive shaft from a 7117 or 17GTH-L or similar.

John U

Share this post


Link to post
Share on other sites
Brettw

The Magnum 20, 18 and KT17 & 19 are all the same physical size and have the same mounting pattern. The Sovereign shown, with power steering, looks to be newer, and may have been powered by a Command or Triad? If this is the case, using those mounting holes (if possible) may also affect where the engine sits in relationship to the driveshaft length.

I had a early KT17 that had the flex plate. The other KT's I have had had the rubber coupler. I may have a driveshaft setup for you, I will need to verify the length you need with the bolt holes you are using.

Share this post


Link to post
Share on other sites
BLT

What you are missing is rubber coupler and that is a NLA item beause few sold as aftermarket parts and the new replacement price shot out of site because of the few needed. Edens Ltd had a kit designed just for that purpose.

Share this post


Link to post
Share on other sites
midnightpumpkin

Dave, I could come over tomorrow and pick up the whole outfit, then you wouldn't have to struggle with it.

I might even give you a small amount of money for it as is.

John U

Share this post


Link to post
Share on other sites
BLT

Also you should have Kohler P/N 237373 Hub and 52 755 29 grass screen kit to adapt you driveshaft to. From what I can see that hub was a Kohler piece made for the Simplicity engine.

Share this post


Link to post
Share on other sites
PhanDad

Based on the way the seat attaches to the seat pan, I agree it's a late model Sovereign. I believe the factory frame holes in your frame look like this:

IMG_4706a.jpg

The pic is of my 75th Anniversary Sovereign. Ignore the "added" "rectangular" holes that are by the 4 factory holes (they are above the factory holes in the pic); they were added by the PO who butchered the Command install. For those of you that know the KT/Magnum bolt pattern, does it look like the holes are there? As to the drive shaft, the stock KT17 with rubber coupling is 17 3/8" flange to flange; the rubber coupling effective thickness is 1 3/4". If the original engine was a Triad, the drive shaft is 17 3/8" flange to flange. This drive shaft does not have the "nose" extension that goes into the rubber coupling. If the original engine was a Command, the drive shaft flange to flange is also 17 3/8" but it has a long "nose" extension. I wouldn't you could use this drive shaft with a KT17/Magnum because the long "nose" would cause interference. (Just my opinion, never tried that combination). You can see pics of the various drive shafts and coupler in the "Drive Shaft Reference" post:http://www.simpletractors.com/club2/topic.asp?TOPIC_ID=119807

IMG_4706a.jpg.1e1a5cabd90416b23354af43d10114b0.jpg

Share this post


Link to post
Share on other sites
PhanDad

Several posts were added while I was composing my response above.

Only the Triad used the plate under the engine. The Kohler KT17 and Command mount directly to the frame as does the Briggs single cylinder engines.

Share this post


Link to post
Share on other sites
MikeES

I have a M20 that replaced a KT17, in a 917. I had to transfer the engine flywheel coupling from the KT engine (same for all Kohler K engines, and M engines) and the existing flex disk bolted right up. Just a little frame trim for the oil filter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • SmilinSam
    • MARK (LI)
    • BLT
  • Today's Birthdays

    1. JoggerFogger
      JoggerFogger
      (48 years old)
  • Recent Status Updates

    • MARK (LI)

      MARK (LI)  »  Alltractoredup

      ...This is Mark from Long Island ....Gene told me that you are selling  FEL for a Sunstar....the link he sent me does not take me to it ...I am not on FB myself, but my wife is...is it just on the AC  / Simple group, or is it on the Marketplace?
      · 2 replies
    • F.U.N.

      F.U.N.  »  sandyhillbill

      Dear Sandhillbill
      Can you please copy me on this data, for Sun Star parts list.
      :
      September 12, 2004 Mike I sent you a PM and have all the mfgs. available for the tiller/hitch/pto/liftgroup if you need me to send them to you. Let me know. Thanks, F.U.N.    
      · 0 replies
  • Adverts

×