Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Bruker

Cause of deck vibration?

Recommended Posts

Bruker

The mower is a Prestige with the 50" deck. When I engage the blades there's quite a bit of vibration and shaking of the deck. I checked the balance of the blades and they're fine and with the blades mounted the arbors spin smooth. The deck drive belt seems to be dancing around quite a bit but I'm not sure if that's the cause or an affect of the vibration. Any ideas?

Share this post


Link to post
Share on other sites
RayS

bearings ok? I know on mine one time I did not have the blade seated correctly in the washer that fits in the blade and it vibrated until I took the blade off and reinstalled correctly. It was cocked on the washer. That was on my Prestige. Also make sure that the idler arm is moving correctly. They seize up even with the grease zerk that is there.

Share this post


Link to post
Share on other sites
Burntime

I have seen also where someone hit the edge of the deck on something and bent the mounting hardware and cocked the deck. I had the deck off three times before I realized the deck shell was caved in one spot. Moral of the story is, never be too smart!:D

Share this post


Link to post
Share on other sites
Brettw

The arbors may seem to spin smoothly, but I would disconnect them from the driven belt and check them individually. With the tension on them from the idler pulley and turning them by hand you might not be able to notice bad bearings.

Share this post


Link to post
Share on other sites
Bruker

I tore it apart this morning and here's what I found.

-The blades are straight and balanced.

-The idler arm is free and moves fine.

-The bearings are good.

-The belt is good.

What I did find is that the arbor that is connected to the drive belt was slightly out of whack. The shaft was fine so I switched the out of whack arbor and the center arbor and now it runs much smoother. I know I should replace the center arbor but the way my F-I-L treats it there will be more carnage this fall.

Just for kicks I also switch the drive belt with one off of my deck and it's now very smooth. Even thought the belt looks like it's good it must be stretched or out of balance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    There are no registered users currently online

  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • F.U.N.

      F.U.N.  »  sandyhillbill

      Dear Sandhillbill
      Can you please copy me on this data, for Sun Star parts list.
      :
      September 12, 2004 Mike I sent you a PM and have all the mfgs. available for the tiller/hitch/pto/liftgroup if you need me to send them to you. Let me know. Thanks, F.U.N.    
      · 0 replies
    • gwiseman

      gwiseman

      Club banners are available  for members use during show season https://simpletractors.com/forums/topic/57849-simpletractors-club-banners-available/
       
      · 0 replies
  • Adverts

×