Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
chindo34

Voltage keeps rising

Recommended Posts

chindo34

Hey guys, quick question for you electricity gurus on these tractors of ours.

My baron 7013H won't charge my battery so after starting my tractor up I test voltage at the battery see if i have 14v or so while running i noticed that it kept on rising and rising I finally turned it off at 18.7v.

Any idea as to why this would be?? Is there a way to test my voltage regulator somehow

Share this post


Link to post
Share on other sites
HubbardRA

Take the top off your voltage regulator and see if you have a set of contacts that is fused closed. If so, then pop them apart with a screwdriver and use a small file to clean the contacts up to a smooth shiny surface again. Probably will work fine after that. If not, then buy a new voltage regulator.

Share this post


Link to post
Share on other sites
chindo34

Thanks HubbardRA that's exactly what I was looking for. Hopefully just a little cleaning and she will regulating her voltage again:D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • bowhunt4life
    • GregB
    • bruker1
    • BLT
  • Today's Birthdays

    1. B-16_IC
      B-16_IC
      (46 years old)
    2. Flannelman
      Flannelman
    3. Glen112
      Glen112
      (71 years old)
  • Recent Status Updates

    • Bubba1997

      Bubba1997

      Searching for a Sleeve hitch and breaking plow and other equipment if price is right and also a deck for a B1 thank you 
      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×