Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
peterinbrooklyn

landlord dlx charging problem

Recommended Posts

peterinbrooklyn

I have a 20hp vanguard in my 01 landlord dlx. I just replaced the battery. But after I mow it won't restart and the battery is dead. I charge it and its good to go. Any ideas why its not charging while running?

Share this post


Link to post
Share on other sites
RayS

Could be the stator or regulator. Check AC volts of stator and DC volts of regulator. Do you have pictures of the regulator, that you can post?

Share this post


Link to post
Share on other sites
mwells

In my experiance with these it has either been a bad regulator or bad connection at the regulator. I can't say that I've ever seen a stator go bad, but anything is possible.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • BLT
    • wsherm
    • Bill725
    • s_stephen
    • abu507
  • Today's Birthdays

    1. pitt
      pitt
      (53 years old)
  • Recent Status Updates

    • Bubba1997

      Bubba1997

      Searching for a Sleeve hitch and breaking plow and other equipment if price is right and also a deck for a B1 thank you 
      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×