Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
chadinabnit

Engine issues

Recommended Posts

chadinabnit

My 725 will idle roughly and with some adjustment run pretty smoothly. The issue is whenever I put any type of load on the engine it will not stay running. Either putting the blades on or putting it in gear. I have cleaned the carb, put a new spark plug in, and new fuel in. Anyone else ever dealt with this issue? I am worried that I might be loosing compression.

Share this post


Link to post
Share on other sites
Tonyvdb

Probably not a lack of compression, I've had the compression get so bad that my 3410 wouldn't start without a squirt of brake cleaner but once running went ok. I'd first look at the governor to be sure it's working properly.

Share this post


Link to post
Share on other sites
Rick3410

Sounds like ignition to me. Double check the point gap and be sure it's still set properly. Sometimes the factory point settings are not optimal as well. If you use an in line spark tester, you can set the points to the strongest (brightest) spark.

Share this post


Link to post
Share on other sites
DMKNLD

My 7114 K321 was doing the same thing - it started to just run rough and miss when it was hot, and gradually got worse. I tried throwing fuel and ignition parts at it, some of which my tractor did need, like a carb rebuild and a new coil and condenser, new throttle shaft and bronze bushing, new fuel and air filter and spark plug, etc, but it still wouldn't run right. I could get it to start and idle, but as soon as I added throttle it would miss and knock and then die.

It ended up being my camshaft, which has a flaired pin that holds the cam in place in the block, and that pin had worn enough that there was slop in the cam, which altered the cam lobe / points pin connection and randomly frigged the timing up. After days of frustration, waiting on being ready to turn my 7114 into 'a burning man shrine', I ended up crying uncle and taking it to my local small engine guy, who ended up having to pull the engine and found the slop in the cam pin, so he fabricated a pin replacement that wouldn't allow the cam to move around. With a 30 yr old tractor, I guess stuff that like comes with the territory. It's running great again, with pretty much a complete overhaul, including an engine rebuild last fall.

So if you've seemingly tried everything like I did, and ruled out fuel and spark issues, as well as the common ignition parts issues, it may be a timing related cam problem.

Share this post


Link to post
Share on other sites
chadinabnit

Haven't done anything with the points since I got the thing. Replaced all the gaskets last year when troubleshooting to get it running properly. Ended up being a bad coil then and put a new one on. Thinking about taking the engine down to parade rest and rebuilding it completely. Did lap the valves last year but one still did not look that great.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • dhoadley
    • 720nut
    • landlord2110
    • rokon2813
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • Bubba1997

      Bubba1997

      Searching for a Sleeve hitch and breaking plow and other equipment if price is right and also a deck for a B1 thank you 
      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×