Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Paul_B

Kohler Command Hot Start Problem

Recommended Posts

Paul_B

The 18hp Kohler Command in my sovereign has become difficult to start when at operating temps. If I shut it down and restart it after ~10 minutes it will run real rough and belch out black smoke. After a few seconds it clears up and will run fine.

If I close the manual fuel shutoff valve it will still do the same thing. If I shut off fuel and run some fuel out of the carb, it makes hot starts much better.

The engine runs great with no apparent issues otherwise.

Is this a float/needle valve issue?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • AllisChalmers716
    • abu507
    • GregB
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • Bubba1997

      Bubba1997

      Searching for a Sleeve hitch and breaking plow and other equipment if price is right and also a deck for a B1 thank you 
      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×