Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
OrangeMetalGuy

Figured out my deck problem

Recommended Posts

OrangeMetalGuy

48"-er newly restored. Last week started to hear a metal screeching sound. Turns out the key-way in the center (lower) pulley (the one that drives the belt for the other arbors) tore out and the pulley was just coasting wearing a much wider hole inside.

Fortunately no damage to anything else... so just a new pulley and key and I am back in business.

But why would it self-destruct like this, unless that pulley (which was original) was weak?

I checked each arbor to make sure they turned easily... all new bearings for all of them. They spin with just a slight bit of resistance.

Share this post


Link to post
Share on other sites
hamman01

Still in the process of restoring the Homelite 48" deck. When I removed the pulleys from the spindles there were no set screws in any of them. They were tight on the spindles but without any set screws. Glad they stayed tight. These were original eeuipment and parts from 1972. Roger.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • BLT
    • abu507
    • AllisChalmers716
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • Bubba1997

      Bubba1997

      Searching for a Sleeve hitch and breaking plow and other equipment if price is right and also a deck for a B1 thank you 
      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×