Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Spitfire

Starter Generator Bracket

Recommended Posts

Spitfire

If anyone has any measurements or specifics of the lower starter/gen mounting bracket of a 16hp single cylinder briggs off my 7016h, I would greatly appreciate it. The one that came bolted on my tractor is the homemade variety, and when I hooked up the snowblower, it rubs on the rod to engage the front pto. The bracket must be close but I would like to get it as close to original as possible.

genbelt.jpg

genbelt.jpg.42cd06398d532159e226e8c477ae0013.jpg

Share this post


Link to post
Share on other sites
rickpilgrim

My first impulse would be to get my 4" angle grinder and "adjust" the bracket for the front pto rod. My 3416's control rd rubbed on both the frame and the start gen also but not much. Hopefully someone will chime in here with the measurements you need.

Share this post


Link to post
Share on other sites
ReedS

With the exception of the two gussets the bracket looks fairly factory, the best that I can see from the photo. It looks to me like your belt is hitting the pto rod. Is the belt correct? If's too long or stretched the S/G will "hang" out too far.

Share this post


Link to post
Share on other sites
Spitfire

A stretched belt is definitely a possibility. The belt is pretty old. I have ordered a new belt as well as the top mounting bracket. The PO had rigged the top up with a piece of angle iron.

rps20131203_210637.jpg

If the bottom bracket is close enough, hopefully the new upper bracket and belt will solve the problem.

rps20131203_210637.jpg.944e4c842886cecb707dba092f5acfc7.jpg

Share this post


Link to post
Share on other sites
PhanDad

At least 2 different types of S/G mounting brackets were used on Simplicity, A/C, and Homelite tractors. They take different belts - 37.5" vs 39.1". My A/C B110 and Hometlite T-12 take the smaller belt; a Simplicity 7016H takes the larger belt.

You may have the wrong belt for the bracket on the engine. I've found "non matching" brackets vs the specs on some tractors. The mounting bracket weldments do crack and the POs probably replaced the bracket with the "other" type.

I'll see if I can find a bracket later today and post a pic with dimensions.

Share this post


Link to post
Share on other sites
Spitfire

Got my new top bracket and belt installed today. Sure enough, everything clears nicely. The old belt was a tad longer than the new one. Got the starter/gen rebuilt and now she starts up real nice!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×