Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
killbasser

sunstar spuddering

Recommended Posts

killbasser

the machine starts fine. sounds good but when i move the lever forward to move its starts to spudder put it neutral it sounds great it has fresh gas new plugs do think its time for a tune up thanks for the help!

Share this post


Link to post
Share on other sites
PeppyDan

Definitely electrical! I had this same thing happen to one of my Sunstars several years back and as I recall it was one of the three micro switches just under the dashboard by the control lever.

Dan

Share this post


Link to post
Share on other sites
killbasser

I think dan is right noticed two contacts when moving lever to right

top one neutral pushed that in still sputterd pushed the bottum one also using pencil toward left stopped sputtering will try that fix where can i get that part

Thanks Bill

Share this post


Link to post
Share on other sites
joelk

Definitely electrical. There are three switches that all make/break at the same time when lever moves in and out of neutral. To get you going remove the wire from the bottom switch, and you'll be good to go. Unfortunately you will loose a safety.... good luck on figuring that out.

Share this post


Link to post
Share on other sites
joelk

I doubt the switch is bad, it is at best case a ground that is bad, but most likely your interlock module is failing. I have read a lot about this issue and haven't got all the electrical straight yet, but let me know if I can help or if you figure anything out let me know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×