Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
Noly

AGCO FC 1313H trans problems

Recommended Posts

Noly

Son just bought AGCO FC 1313Hydro. Previous owner said trans has problems. Finally got it running and when trans is in forward the machine moves backwards. Does nothing when when trans is in reverse. Any ideas neither one of us are knowledgeable about these. Thanks

Share this post


Link to post
Share on other sites
Ronald Hribar

The only thing that I can think of is there is a hydro release lever. Make sure that is not actuated. Did you check linkage to make sure it is moving shift lever on transmission

I has been a couple of years since I had mine. Todd Bader has at least one also

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • mikeman
    • PhanDad
    • hurleyii
    • Rvcjacobsen
  • Today's Birthdays

    1. Carchief
      Carchief
      (57 years old)
    2. Geoff
      Geoff
      (56 years old)
    3. mohrds
      mohrds
      (51 years old)
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 2 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×