Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
hurleyii

Sickle mower installation how's?

Recommended Posts

hurleyii

Ok so I have a sickle mower that came with my 3415s I'm going to install on the 912 tomorrow . How do I do this pics would be great. Also I have a double v belt I found in all the parts does anybody know what that's for?

Share this post


Link to post
Share on other sites
GregB

Is it the newer style planetary unit?

Here's a link to installing the older B series, mounting should be similar but PTO hookup is different.

https://www.simpletractors.com/operation/46_sickle_bar.htm

if it is the 1690030, here's a link to owners manual and parts list

http://www.simplicitymfg.com/us/en/support/manuals/results?search=1690030

Share this post


Link to post
Share on other sites
Chris727

It will not directly work on the 900/7100 series tractors. You will have to use a longer belt. Did you get the cable pulley bracket with it? Mods are needed in order to attach the bracket. Josh has done this on his 917.

Share this post


Link to post
Share on other sites
hurleyii

The spring is loose on one side what does it connect to? The whole I see to the right is my assumption.

Yes I have the pulley bracket that's for the lift its currently on the side of the 3415s. I also have the wood board thingy and the belts I think.

Share this post


Link to post
Share on other sites
hurleyii

Ok guys thanks for all the help. Between the info I got from you guys here and on 9020 sickle mower post I got it all figured out. Greased it oiled it and hooked it up and walla! I have to modify for the cable lift bracket and the chain support but I had it working and had to grease it again and overall it sounds great!! FYI the belt that came with the 3415s did work but I don't know if that belt was meant for the sickle, the 48" deck, or the 36" snow blower. I did have to grease again as it was a little loud but seems to have gotton quiet after the second greasing and further oiling!

Thanks again guys for all the help! Now its time to go build another shelf in the garage to get these attachments up and out of the way like they belong. Then to fix the the points bushing issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • Larrybell57
    • AC710
    • simGTH16
  • Today's Birthdays

    1. Chris727
      Chris727
      (37 years old)
    2. jdwilson
      jdwilson
      (65 years old)
  • Recent Status Updates

    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
    • thedaddycat

      thedaddycat  »  SmilinSam

      It's in pretty sad shape, but yes I have a yellow plastic cap that I'm fairly certain is what you need. PM me your details and I'll get it out to you.
      · 0 replies
  • Adverts

×