Jump to content

Unofficial Home of Old Simplicity & Allis-Chalmers Garden Tractors

Sign in to follow this  
yukon

legacy

Recommended Posts

yukon

well i found out what was wrong with my legacy AFTER REPLACING THE MAIN WIRING HARNESS I FOUND THAT IT WOULDNT CHARGE so i pulled the engine what i found was a magnet fell off the flywheel and tore the stator up after replacing everything i found that it runs and mowes great. heres some pics.

001.JPG

002.JPG

003.JPG

001.JPG.69362859fd1802c8b06b6fdf605ce980.JPG

002.JPG.38717c55b21e5fb1a9a75dee7c8b27df.JPG

003.JPG.8ca068641a7e41e329b5b568e1120e80.JPG

Share this post


Link to post
Share on other sites
RedbarnRick

Great tractor, I have the diesel model like yours, I put that tractor thru heck and it just keeps ticking, there's a front end loader in classifieds, I have one on mine and use it constantly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Who's Online (See full list)

    • Groundhog76
    • SmilinSam
    • Tom45
    • abu507
    • tamurmueen
    • PhanDad
    • gwiseman
    • Brettw
  • Today's Birthdays

    No users celebrating today
  • Recent Status Updates

    • SonOfCreepfeed

      SonOfCreepfeed

      Thinkin' about this old girl.

      · 3 replies
    • Dean McFadden

      Dean McFadden

      Good morning peeps! I’m always searching for helpful information with my AC collection. Hope to find out new information and pass on my own experience in restoration. Here are some pics of my babies. I’m still looking for front rims for the 410 so yesterday I put the 310 wheels on took it for a drive. Working pretty good but still needs some carb work. Gotta get the 310 running next. Have a great day!😁
       

      · 1 reply
  • Adverts

×